RIPv2 di Cisco

RIP adalah prokotol routing distance vector. RIP menentukan jalur terbaik dengan menghitung jumlah hop yang paling sedikit. Hop disini maksudnya berapa router yang dilewati untuk menuju network tujuan. Kali ini saya akan share bagaimana konfigurasi RIPv2 di Cisco.

Topologi

image4155

Pada lab kali ini, protokol routing yang digunakan adalah RIP. Goalnya adalah menghubungkan PC1 dan PC2, kemudian traceroute dari PC1 ke PC2. Lihat mana path yang digunakan apakah melaui R3 atau R2 dan R4.

Konfigurasi

Di IDN-R1:

IDN-R1(config)#router rip

Lihat atribut apa saja yg dapat digunakan.

IDN-R1(config-router)#?
  auto-summary         Enter Address Family command mode
  default-information  Control distribution of default information
  distance             Define an administrative distance
  exit                 Exit from routing protocol configuration mode
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  passive-interface    Suppress routing updates on an interface
  redistribute         Redistribute information from another routing protocol
  timers               Adjust routing timers
  version              Set routing protocol version

Yang akan digunakan adalah version, auto-summary, network, redistribute, passive-interface.

IDN-R1(config-router)#version 2
IDN-R1(config-router)#network 12.12.12.0
IDN-R1(config-router)#network 13.13.13.0
IDN-R1(config-router)#distributed connected
IDN-R1(config-router)#redistribute connected 
IDN-R1(config-router)#no auto-summary
IDN-R1(config-router)#passive-interface fa1/0

Di IDN-R2:

IDN-R2(config)#router rip
IDN-R2(config-router)#version 2
IDN-R2(config-router)#network 12.12.12.0
IDN-R2(config-router)#network 24.24.24.0
IDN-R2(config-router)#no auto-summary

Di IDN-R3:

IDN-R3(config)#router rip
IDN-R3(config-router)#version 2
IDN-R3(config-router)#network 13.13.13.0
IDN-R3(config-router)#network 35.35.35.0
IDN-R3(config-router)#no auto-summary

Di IDN-R4:

IDN-R4(config)#router rip
IDN-R4(config-router)#version 2
IDN-R4(config-router)#network 24.24.24.0
IDN-R4(config-router)#network 45.45.45.0
IDN-R4(config-router)#no auto-summary

Di IDN-R5:

IDN-R5(config)#router rip
IDN-R5(config-router)#version 2
IDN-R5(config-router)#network 35.35.35.0
IDN-R5(config-router)#network 45.45.45.0
IDN-R5(config-router)#redistribute connected
IDN-R5(config-router)#no auto-summary
IDN-R5(config-router)#passive-interface fa1/0

Lihat tabel routing di IDN-R1

IDN-R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, FastEthernet0/1
     24.0.0.0/24 is subnetted, 1 subnets
R       24.24.24.0 [120/1] via 12.12.12.2, 00:00:14, FastEthernet0/0
     35.0.0.0/24 is subnetted, 1 subnets
R       35.35.35.0 [120/1] via 13.13.13.3, 00:00:00, FastEthernet0/1
     45.0.0.0/24 is subnetted, 1 subnets
R       45.45.45.0 [120/2] via 12.12.12.2, 00:00:14, FastEthernet0/0
                   [120/2] via 13.13.13.3, 00:00:00, FastEthernet0/1
C       192.168.1.0/24 is directly connected, FastEthernet1/0
R       192.168.5.0/24 [120/2] via 13.13.13.3, 00:00:00, FastEthernet0/1

R menunjukan protokol yang digunakan adalah RIP
[120/2] angka 120 adalah administrative distance dan 2 adalah hop count

Lihat tabel routing di IDN-R2:

IDN-R5#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

    12.0.0.0/24 is subnetted, 1 subnets
R       12.12.12.0 [120/2] via 35.35.35.3, 00:00:08, FastEthernet0/1
                   [120/2] via 45.45.45.4, 00:00:25, FastEthernet0/0
    13.0.0.0/24 is subnetted, 1 subnets
R       13.13.13.0 [120/1] via 35.35.35.3, 00:00:08, FastEthernet0/1
    24.0.0.0/24 is subnetted, 1 subnets
R       24.24.24.0 [120/1] via 45.45.45.4, 00:00:25, FastEthernet0/0
    35.0.0.0/24 is subnetted, 1 subnets
C       35.35.35.0 is directly connected, FastEthernet0/1
    45.0.0.0/24 is subnetted, 1 subnets
C       45.45.45.0 is directly connected, FastEthernet0/0
R       192.168.1.0/24 [120/2] via 35.35.35.3, 00:00:08, FastEthernet0/1
C       192.168.5.0/24 is directly connected, FastEthernet1/0

Traceroute di PC1 menuju PC2

PC>tracert 192.168.5.2

Tracing route to 192.168.5.2 over a maximum of 30 hops:

 1   1 ms     0 ms     0 ms     192.168.1.254
 2   0 ms     0 ms     0 ms     13.13.13.3
 3   0 ms     0 ms     0 ms     35.35.35.5
 4   0 ms     0 ms     0 ms     192.168.5.2

Trace complete.

Berdasarkan hasil traceroute, path yang digunakan adalah melalui router R1->R3->R5.

path4182

RIP menentukan path hanya berdasarkan hop, dia tidak bisa memperhitungkan bandwidth dari jalur tersebut. Makanya RIP saat ini sudah tidak digunakan. Penggantinya adalah OSPF. Anda dapat membaca postingan saya tentang konsep OSPF dan OSPF di Cisco

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s