[Lab-1] Superlab41

Superlab merupakan kumpulan lab yang dibuat untuk melatih kemampuan anda dalam mengkonfigurasi cisco devices. Superlab ini ditujukan untuk anda yang sebelumnya sudah pernah melakukan konfigurasi cisco devices. Kali ini saya akan share pembahasan superlab 41. Dalam superlab 41, anda dapat berlatih OSPF, BGP, EIGRP, PAT, NAT, juga Wireless. Untuk lebih jelasnya, anda dapat melihat bagian topologi, tujuan, dan penyelesaian.

Topologi

Screenshot_7e.png

Bagi anda yang ingin mencoba mengerjakan superlab ini, saya sudah menyiapkan file pkt kosong jadi anda tinggal konfigurasi saja. Anda dapat mengunduh file pkt nya di Download pkt superlab 41

Tujuan Lab:

  1. AS 10 dan AS 20 dapat saling interkoneksi menggunakan BGP
  2. NAT untuk IDN-Server1 dari ip 192.168.10.1 menjadi 13.13.13.3 khusus port 80
  3. PAT untuk network 192.168.1.0 sehingga dapat mengakses IDN-Server1
  4. IDN-Server2 (ftp server) hanya dapat diakses oleh network local (192.168.1.0/24)
  5. Smartphone1 & 2 bisa mengakses website IDN (http://13.13.13.3)
  6. PC2 tidak diizinkan mengakses 13.13.13.3

Materi Lab:

  1. Routing OSPF
  2. Routing BGP
  3. Routing EIGRP
  4. Redistribution
  5. NAT
  6. PAT
  7. Access List
  8. Wireless

Gambaran keseluruhan konfigurasi:

Karena dalam superlab ini terdapat dua autonomous system, maka kita perlu menyelesaikan konfigurasi satu per satu disetiap as kemudian menghubungkan kedua as tersebut.

Penyelesaian

Pertama, selesaikan semua konfigurasi untuk as 10.

Konfigurasi pada IDN-R4

1. Enable, masuk ke mode konfigurasi terminal, kemudian berikan hostname.

        enable
        configure terminal
            hostname IDN-R4

2. Konfigurasi dan aktifkan interface
       
        interface se4/0
            ip address 14.14.14.4 255.255.255.0
            no shutdown

        interface fa0/0
            ip address 192.168.1.254 255.255.255.0
            no shutdown

3. Konfigurasi OSPF

        router ospf 2
            network 14.14.14.0 0.0.0.255 area 0
            network 192.168.1.0 0.0.0.255 area 0
            passive-interface fa0/0

Pada IDN-R3

1. Enable, masuk mode konfigurasi terminal, ubah hostname

        enable
        configure terminal
            hostname IDN-R3

2. Konfigurasi dan aktifkan interface

        interface se5/0
            ip address 13.13.13.3 255.255.255.0
            no shutdown

        interface fa0/0
            ip address 192.168.10.254 255.255.255.0
            no shutdown

3. Konfigurasi OSPF

        router ospf 10
            network 13.13.13.0 0.0.0.255 area 0
            passive-interface fa0/0

4. Aktifkan NAT pada interface (insinde untuk fa0/0, outside untuk se5/0)

        interface fa0/0
            ip nat inside

        interface se5/0
            ip nat outside

5. Aktifkan NAT untuk port 80 saja  
 
        ip nat inside source static tcp 192.168.10.1 80 13.13.13.3 80

6. Buat access-list (untuk menolak ip 192.168.4.1)

        access-list 10 deny 192.168.4.2
        access-list 10 permit any

6. Atur se5/0 agar masuk ke dalam access-group 10.

        interface se5/0
            ip access-group 10 in

Pada IDN-R1

1. Enable, masuk mode konfigurasi terminal, ubah hostname

        enable
        configure terminal
            hostname IDN-R1

2. Konfigurasi dan aktifkan interface

        interface se4/0
            ip address 12.12.12.1 255.255.255.0
            no shutdown

        interface se5/0
            ip address 14.14.14.1 255.255.255.0
            clock rate 56000
            no shutdown

        interface se6/0
            ip address 13.13.13.1 255.255.255.0
            clock rate 56000
            no shutdown

3. Konfigurasi OSPF

        router ospf 1
            network 13.13.13.0 0.0.0.255 area 0
            network 14.14.14.0 0.0.0.255 area 0

Kemudian selesaikan semua konfigurasi untuk as 20

Pada IDN-R5

1. Enable, masuk mode konfigurasi terminal, ubah hostname

        enable
        configure terminal
            hostname IDN-R5

2. Konfigurasi dan aktifkan interface

        interface se2/0
            ip address 25.25.25.5 255.255.255.0
            no shutdown

        interface fa0/0
            ip address 192.168.3.254 255.255.255.0
            no shutdown

3. Konfigurasi DCHP 

        ip dhcp pool buat-ap
            network 192.168.3.0 255.255.255.0
            default-router 192.168.3.254

4. Konfigurasi EIGRP

        router eigrp 20
            network 25.25.25.0 0.0.0.255
            network 192.168.3.0 0.0.0.255
            passive-interface fa0/0
            no auto-summary

Pada IDN-Wireless

1. Konfigurasi IP address untuk interface se2/0. GUI --> Setup -->
   Pilih DHCP

Screenshot_2e.png
2. Ubah SSID. Buka tab Wireless --> Ubah Network Name (SSID) -->
   Save Settings

Screenshot_1e.png
3. Konfigurasi Wireless security. Pilih tab Wireless --> Wireless Security
   --> Security Mode nya menjadi WPA2 Personal --> Encryption AES -->
   Masukkan password pada kolom Passphrase.

Screenshot_3.png

Pada IDN-R6

1. Enable, masuk mode konfigurasi terminal, ubah hostname

        enable
        configure terminal
            hostname IDN-R6

2. Konfigurasi dan aktifkan interface

        interface se2/0
            ip address 26.26.26.6 255.255.255.0
            no shutdown

        interface fa0/0
            ip address 192.168.1.254 255.255.255.0
            no shutdown

        interface fa1/0
            ip address 192.168.13.254 255.255.255.0
            no shutdown
3. Konfigurasi EIGRP

        router eigrp 20
            network 26.26.26.0 0.0.0.255
            no auto-summary
            passive-interface fa0/0
            passive-interface fa1/0

4. Atur se2/0 menjadi nat outside dan fa0/0 menjadi nat inside

        interface se2/0
            ip nat outside

        interface fa0/0
            ip nat inside

5. Buat access-list untuk network yang akan di-NAT-kan

        access-list 1 permit 192.168.1.0 0.0.0.255

6. Aktifkan PAT

        ip nat inside source list 1 interface se2/0 overload

   (list 1 adalah list ip address yg akan di-NAT-kan, interface se2/0
    adalah out interface

Pada IDN-R2

1. Enable, masuk mode konfigurasi terminal, ubah hostname

        enable
        configure terminal
        hostname IDN-R2

2. Konfigurasi dan aktifkan interface

        interface se2/0
            ip address 12.12.12.2 255.255.255.0
            clock rate 56000
            no shutdown

        interface se3/0
            ip address 25.25.25.2 255.255.255.0
            clock rate 56000
            no shutdown 

        interface se4/0
            ip address 26.26.26.2 255.255.255.0
            clock rate 56000
            no shutdown

3. Konfigurasi EIGRP

        router eigrp 20
            network 25.25.25.0 0.0.0.255
            network 26.26.26.0 0.0.0.255
            no auto-summary

 

Hubungkan kedua AS dengan menggunakan BGP

Pada IDN-R1

1. Konfigurasi BGP
        router bgp 10
            bgp router-id 1.1.1.1
            neighbor 12.12.12.2 remote-as 20
            redistribute ospf 1
            no synchronization

2. Redistribute BGP pada OSPF
        router ospf 1
            redistribute bgp 10 subnets

Pada IDN-R2

1. Konfigurasi BGP
   
        router bgp 20
            bgp router-id 2.2.2.2
            neighbor 12.12.12.1 remote-as 10
            redistribute eigrp 20
            no synchronization

2. Redistribute BGP pada EIGRP

        router eigrp 20
            redistribute bgp 20 metric 1 1 1 1 1

 

Pengujian

1. Kedua AS saling interkoneksi

IDN-R1#show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 10
BGP table version is 11, main routing table version 6
6 network entries using 792 bytes of memory
6 path entries using 312 bytes of memory
3/3 BGP path/bestpath attribute entries using 552 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1736 total bytes of memory
BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.12.12.2      4    20   151     146       11    0    0   02:24:05      4

Juga lihat tabel routing bgp di IDN-R1

IDN-R1#show ip bgp
BGP table version is 11, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 13.13.13.0/24     0.0.0.0                  0     0 32768 i
*> 14.14.14.0/24     0.0.0.0                  0     0 32768 i
*> 25.25.25.0/24     12.12.12.2               0     0     0 20 ?
*> 26.26.26.0/24     12.12.12.2               0     0     0 20 ?
*> 192.168.3.0/24    12.12.12.2               0     0     0 20 ?
*> 192.168.4.0/24    14.14.14.4               0     0     0 10 ?

Lihat bgp summary di IDN-R2

IDN-R2#show ip bgp summary
BGP router identifier 2.2.2.2, local AS number 20
BGP table version is 8, main routing table version 6
6 network entries using 792 bytes of memory
6 path entries using 312 bytes of memory
3/3 BGP path/bestpath attribute entries using 552 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1736 total bytes of memory
BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.12.12.1      4    10     156     153        8    0    0 02:31:53        4

Juga tabel bgp di IDN-R2

IDN-R2#show ip bgp
BGP table version is 8, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 13.13.13.0/24     12.12.12.1               0     0     0 10 ?
*> 14.14.14.0/24     12.12.12.1               0     0     0 10 ?
*> 25.25.25.0/24     0.0.0.0                  0     0 32768 i
*> 26.26.26.0/24     0.0.0.0                  0     0 32768 i
*> 192.168.3.0/24    25.25.25.5               0     0     0 20 ?
*> 192.168.4.0/24    12.12.12.1               0     0     0 10 ?

Dengan melihat kedua hasil diatas, dapat disimpulkan bahwa kedua AS sudah saling interkoneksi.

2. Menguji NAT pada IDN-R3 dari PC-1

Tujuan PAT adalah untuk mentranslasikan port untuk alamat ip tertentu. Karena network 192.168.10.0 tidak diadvertise oleh OSPF maka network lain yang diluar jangkauan router tersebut tidak akan dapat dijangkau. Untuk membuktikannya, anda dapat langsung mengakses ip 192.168.1.

image4155-8.png

Dapat anda lihat, response dari 192.168.10.1:80 adalah Request Timeout yang artinya request http tidak ada respon dari alamat tujuan. Kemudian mari buktikan PAT dengan mengakses 13.13.13.3.

image4155-7

Website IDN dapat diakses melalui PC-1.

3. Menguji PAT untuk network 192.168.1.0 sehingga dapat mengakses IDN-Server1

4. Menguji yang IDN-Server2 (ftp server) hanya dapat diakses oleh network local (192.168.1.0/24). Dengan menggunakan perintah ftp di command prompt, anda dapat login ke ftp idn menggunakan username idn dan password idn123.

Screenshot_5e.png

5. Menguji smartphone 1 untuk mengakses website IDN (http://13.13.13.3)

Screenshot_6e.png

6. Menguji PC2 yang tidak diizinkan untuk mengakses 13.13.13.

Screenshot_7e.png

PC2 tidak dapat mengakses 13.13.13.3 karena sudak di-deny oleh IDN-R3.

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s